gplugin/gplugin

closing this branch as there is no demand for this
feature/ruby-loader
17 months ago, Gary Kramlich
d44bad5e041e
file isExecutable
closing this branch as there is no demand for this
#!/usr/bin/make -f
export DH_VERBOSE = 1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
BUILD_DIR := debian/build
%:
dh $@ --with gir
override_dh_auto_clean:
rm -rf $(BUILD_DIR)
override_dh_auto_configure:
meson --prefix /usr --warnlevel 3 $(BUILD_DIR)
override_dh_auto_build:
ninja -v -C $(BUILD_DIR)
override_dh_auto_test:
ninja -v -C $(BUILD_DIR) test
override_dh_auto_install:
DESTDIR=$(CURDIR)/debian/tmp ninja -v -C $(BUILD_DIR) install