gplugin/gplugin

We don't need GModule in our gir file

6 months ago, Gary Kramlich
1195da375abd
We don't need GModule in our gir file

Testing Done:
Compiled and made sure there was no reference to `GModule` in `GPlugin-1.0.gir`.

Reviewed at https://reviews.imfreedom.org/r/1252/
option(
'doc',
type : 'boolean', value : true, yield : true,
description : 'build documentation with gtk-doc'
)
option(
'introspection',
type : 'boolean', value : true, yield : true,
description : 'Whether or not to build a GObject Introspection type library'
)
option(
'devenv-config-dir',
type : 'string',
description : 'config directory for running a devenv (defaults to a subdirectory of buildroot)'
)
option(
'gtk3',
type : 'boolean', value : true,
description : 'Whether or not to build the GTK3 library'
)
option(
'gtk4',
type : 'feature',
description : 'Whether or not to build the GTK4 library'
)
option(
'help2man',
type : 'boolean', value : true,
description : 'Whether or not to build man pages from --help output'
)
option(
'install-gplugin-gtk3-viewer',
type : 'boolean', value : true,
description : 'Whether or not to install the GTK3 viewer application'
)
option(
'install-gplugin-gtk4-viewer',
type : 'boolean', value : true,
description : 'Whether or not to install the GTK4 viewer application'
)
option(
'install-gplugin-query',
type : 'boolean', value : true,
description : 'Whether or not to install the query application'
)
option(
'lua',
type : 'boolean', value : true,
description : 'Whether or not to build the Lua plugin loader'
)
option(
'nls',
type : 'boolean', value : true,
description : 'Install translation files'
)
option(
'perl5',
type : 'boolean', value : true,
description : 'Whether or not to build the Perl plugin loader'
)
option(
'python3',
type : 'boolean', value : true,
description : 'Whether or not to build the Python 3.x plugin loader'
)
option(
'rs',
type : 'boolean', value : false,
description : 'Whether or not to create the rust bindings.'
)
option(
'tcc',
type : 'boolean', value : false,
description : 'Whether or not to build the TCC plugin loader'
)
option(
'vapi',
type : 'boolean', value : true,
description : 'Whether or not to build vapi files for gplugin'
)